System Wide Issue
Incident Report for Trakstar Perform
Resolved
The issue is resolved. Should you face further problems, please reach out at perform@trakstar.com.
Posted Mar 07, 2022 - 13:24 PST
Monitoring
The system has recovered - we are reviewing the root cause.
Posted Mar 07, 2022 - 13:10 PST
Investigating
We are currently investigating a system wide issue.
Posted Mar 07, 2022 - 13:08 PST
This incident affected: Trakstar Perform (Application).